Jump to content


Graphics Adapter Not supported?


  • This topic is locked This topic is locked
3 replies to this topic

KnightConcorde #1 Posted 30 September 2012 - 08:10 PM

    Senior Airman

  • Closed Beta Tester
  • 0 battles
  • 17
  • Member since:
    04-06-2012
I've been getting this error every time I load the game. I don't know how to fix it, and I don't want to have to go buy a new computer and/or graphics card. Here's the error:

CRITICAL: Your graphics adapter supports vertex shaders version 2. Version 3 is required. Please upgrade your hardware.

Anyone else getting this error, and is there a way to fix it without having to get a new computer and/or hardware?

monstaknight #2 Posted 30 September 2012 - 09:04 PM

    Senior Airman

  • Closed Beta Tester
  • 20 battles
  • 28
  • Member since:
    02-06-2012
Go to systemrequirementslab.com and test wot (Because wot and wowp have the same graphics I think) It should show some suggestions after the analyis.So yea you may need to buy a new computer or graphics card. :Smile_sad:

Alesia_Aisela #3 Posted 30 September 2012 - 09:15 PM

    Command Chief Master Sergeant

  • Alpha tester
  • 6 battles
  • 579
  • [BUNS] BUNS
  • Member since:
    10-21-2011

View Postmonstaknight, on 30 September 2012 - 09:04 PM, said:

Go to systemrequirementslab.com and test wot (Because wot and wowp have the same graphics I think) It should show some suggestions after the analyis.So yea you may need to buy a new computer or graphics card. :Smile_sad:

Well, it basically means your running a very old vid card, or a weird recent one that doesn't support Shader model 3, if this isn't a bug you will have to update to a newer card.  (you can snag one for a cheap ~$35 USD on Newegg, so it's shouldn't be too bad unless you want to do a major upgrade)


RIP carlr the moderator june 11, 2012.


dafrandle #4 Posted 30 September 2012 - 09:58 PM

    Airman Basic

  • Closed Beta Tester
  • 49 battles
  • 9
  • [-REAP] -REAP
  • Member since:
    01-26-2012

View Postmonstaknight, on 30 September 2012 - 09:04 PM, said:

Go to systemrequirementslab.com and test wot (Because wot and wowp have the same graphics I think) It should show some suggestions after the analyis.So yea you may need to buy a new computer or graphics card. :Smile_sad:
wot and wowp do not have the same gapics i can run wot mutch better than i can wowp


View PostBrann, on 30 September 2012 - 09:15 PM, said:

Well, it basically means your running a very old vid card, or a weird recent one that doesn't support Shader model 3, if this isn't a bug you will have to update to a newer card.  (you can snag one for a cheap ~$35 USD on Newegg, so it's shouldn't be too bad unless you want to do a major upgrade)

i dont think a 35 buck grapics card is gonna runn this game above 10fps

my suggestion is this, it a little expensive but it will give you what you want
http://www.amazon.co...=Radeon HD 6770

Edited by dafrandle, 30 September 2012 - 10:01 PM.


you can view my tf2 backpack here www.tf2items.com/profiles/76561198020576899

this is just stuff i try to put in all my sigs, deal with it




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users