Jump to content


Guns won't fire on first click when aiming at a plane

Gun/mouse issues

  • Please log in to reply
6 replies to this topic

Mojoe_Bailey #1 Posted 28 April 2018 - 08:57 AM

    Master Sergeant

  • Member
  • 1443 battles
  • 45
  • Member since:
    02-03-2018

I'm not sure it is my mouse that is the problem. It is a very good mouse so far. Just recently I have found that when I line things up and shoot, the guns won't go off. I try again. 2nd or 3rd try the guns finally fire. Is this a mouse issue? What kind of issue could it be and how do I fix it? Buy a new mouse? 

 

I just want to be sure before I go purchase a new mouse. It could be a game glitch that other people are experiencing right now. The mouse seems to work fine for other things, like clicking the X on the internet or highlighting words. Please offer some suggestions and possible fixes. It might be the game's fault, might be my mouse. 


Edited by Mojoe_Bailey, 28 April 2018 - 08:58 AM.


gerr22 #2 Posted 28 April 2018 - 09:11 AM

    Senior Master Sergeant

  • Member
  • 2771 battles
  • 459
  • [S-S-G] S-S-G
  • Member since:
    12-27-2013

two things do you have another mouse to try 

is your mouse wireless the low end mouse mice do that

you may have a slight latency problem if on a wireless connection

what is your ping like

off the cuff those are some of the things that may give that type of problem 

 



Perco_lator #3 Posted 28 April 2018 - 01:29 PM

    Command Chief Master Sergeant

  • Member
  • 11 battles
  • 638
  • Member since:
    08-15-2015

It's most likely packet loss.

Make sure you don't have anything running in the background while playing.

Close the Game Center down completely from your task bar after starting the game as it has been known to cause lag issues.


"Come find me in the game, tough guy.  We'll see who knows stuff."


Claudio67 #4 Posted 28 April 2018 - 03:20 PM

    Second Lieutenant

  • Open Beta Tester
  • 423 battles
  • 1,546
  • Member since:
    08-03-2013
Try using your keyboard...

DataNinja #5 Posted 28 April 2018 - 08:26 PM

    Master Sergeant

  • Member
  • 7234 battles
  • 54
  • [OWSS] OWSS
  • Member since:
    09-26-2016

My joystick does this too....but won't fire...not just first click....

I now test guns at beginning of game or respawn...if don't work, hit escape and tab...and escape back....usually clears it.



Pogo68 #6 Posted 28 April 2018 - 09:31 PM

    Second Lieutenant

  • Member
  • 1649 battles
  • 1,377
  • [-BFS-] -BFS-
  • Member since:
    11-06-2012

Most often it's latency.

Start out with a clean slate.

Clear cache, shut down all programs you don't need and reboot your router as well.

I'm finding that my router and modem start slowing down after a few days of operation.

My ISP throttles traffic, rebooting the modem forces the ISP to reset the connections.


Edited by Pogo68, 28 April 2018 - 09:32 PM.

DICTA BOELCKE for WoWP
    1. Try to secure the upper hand before attacking.
    2. Always continue with an attack you have begun
    3. Open fire only at close range, and then only when the opponent is squarely in your sights
    4. You should always try to keep your eye on your opponent, and never let yourself be deceived by ruses
    5. In any type of attack, it is essential to assail your opponent from behind
    6. If your opponent dives on you, do not try run away from his attack, but fly to meet it
    7. When over the enemy's lines, always remember your own line of retreat
    8. It is better to attack in groups of four or six. Avoid two aircraft attacking the same opponent

Mojoe_Bailey #7 Posted 01 May 2018 - 04:49 PM

    Master Sergeant

  • Member
  • 1443 battles
  • 45
  • Member since:
    02-03-2018
Ok. I will try clearing the cache. That might help. Resetting router, will try. Because it is definitely not the mouse. I bought a new mouse and it works fine for everything and every other game, just not warplanes. When I left click, it does not fire on the first click. There is so much hesitation. And I almost lost a dogfight with a Yak the other day because my guns would not fire when I desperately needed them to. I had a clear shot and it was wasted because of this stupid issue. 




1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users