Jump to content


How Throttle SHOULD Work


  • This topic is locked This topic is locked
48 replies to this topic

EvilP #41 Posted 13 August 2012 - 02:44 AM

    Airman Basic

  • Closed Beta Tester
  • 0 battles
  • 2
  • Member since:
    01-26-2012
I don't know how it worked before, I just started tests. Now we got "boost" button, but still max throtle button position = boost. And agree with previous posts - it shouldn't work like this.

sonza68 #42 Posted 14 August 2012 - 07:40 PM

    Senior Master Sergeant

  • Alpha tester
  • 0 battles
  • 133
  • Member since:
    01-26-2012
Personally I like the max throttle = boost.  Since my only real sim experiece is in afterburning jets, mentally, the engine's normal max throttle translates to Mil power for me and boost translated to a time limited AB.  The only real difference is the lack of a detent in the throttle.

I will admit, I didn't like the boost point being at 50% like it was back in alpha, but with the boost setting at 80-90% like it is now, I find it very natural.

Edited by sonza68, 14 August 2012 - 07:42 PM.


Kanzig #43 Posted 14 August 2012 - 11:30 PM

    Master Sergeant

  • Alpha tester
  • 6 battles
  • 50
  • Member since:
    01-26-2012
I hate the boost being attached to the throttle axis.  The boost button should be separate and only triggered when I hit that button.

Oheson #44 Posted 15 August 2012 - 01:09 AM

    Senior Airman

  • Closed Beta Tester
  • 0 battles
  • 28
  • Member since:
    01-09-2012
This throttle thing is just confusing.  What has changed since the last patch?  I simply can not play the game because of this.  I start out ok then the engine just dies.  My joystick thrust no longer works and I have to repeatedly keep pressing the "=" key to keep the engine running.

What is the deal with this?  It is too frustrating to play atm.

Edited by Oheson, 15 August 2012 - 01:26 AM.


Jinxed_Katajainen #45 Posted 15 August 2012 - 01:41 AM

    Feedback Airedale

  • Alpha tester
  • 47 battles
  • 2,444
  • Member since:
    01-28-2012

View PostOheson, on 15 August 2012 - 01:09 AM, said:

This throttle thing is just confusing.  What has changed since the last patch?  I simply can not play the game because of this.  I start out ok then the engine just dies.  My joystick thrust no longer works and I have to repeatedly keep pressing the "=" key to keep the engine running.

What is the deal with this?  It is too frustrating to play atm.

I've been having a bunch of issues myself with the throttle..  (all of these have been ticketed)

Throtte cuts to half, then becomes unresponsive
Throtte axis reverses randomly
Throttle doesn't move all the way to 100% unless I set to 0% power then raise it again
Cannot take boost off the throttle.  It is mapped to inc/dec throttle and boost is mapped to a button.

ezra29 #46 Posted 16 August 2012 - 11:31 AM

    Airman Basic

  • Closed Beta Tester
  • 0 battles
  • 4
  • Member since:
    01-26-2012
Very true dude! Thanks for putting this up! Saved me the trouble! ;)

Diligence #47 Posted 16 August 2012 - 12:28 PM

    Master Sergeant

  • Alpha tester
  • 0 battles
  • 81
  • Member since:
    01-26-2012

View Postezra29, on 16 August 2012 - 11:31 AM, said:

Very true dude! Thanks for putting this up! Saved me the trouble! ;)

Has anyone ever seen any response from WG about the throttle and WEP/Boost? It has only been 8 months since this post.

And the collective time the testers have spent posting, researching and trying to work-around the issue of WEP/engine boost and the throttle control is astonishing.

TheFishlord #48 Posted 17 August 2012 - 02:25 AM

    Master Sergeant

  • Closed Beta Tester
  • 0 battles
  • 60
  • Member since:
    01-26-2012
I'm coming back to this after a few weeks of absence - I assume the "point of normal thrust" fix doesn't work anymore?

Edited by TheFishlord, 17 August 2012 - 02:26 AM.


Tycorama #49 Posted 18 August 2012 - 03:10 PM

    Airman Basic

  • Closed Beta Tester
  • 0 battles
  • 1
  • Member since:
    08-17-2012
I agree with the majority of the posters

1. That the boost should not be pegged to the throttle..

2. That a seperate bar indicating how much of the throttle we are at.. rather than just max or idle

Also with thrust, i feel it lags in response to any action other than boost and could do with some minor tweaking.




1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users